No mockup camera active when playing

  • Issue category: Mockup camera not active
  • Device type & OS version: iOS
  • Host machine & OS version: Mac
  • Issue Environment : Unity Mock
  • ARDK version: 1.0.1
  • Unity version: 2021.2.3f1

Description of the issue:
So I’ve been following the placement tutorial and everything seemed to work fine until I tried to play the scene and realized that I’m not getting the view of the mockup camera at all.

Anybody having a similar issue and a possible solution?


Hey Arnaud,

I wonder, do you have a MockupScene object and have set the “Layer” tag to “ARDK_MockWorld”? You’ll need that if not done already.

I’ve not tried with Unity2021, there could be unforseen issues, maybe give 2019 LTS a try. The exact version is in the docs and on a recent post somewhere yesterday. Hope these help.


Hi Arnaud,

One reason to get a similar behavior as you stated - “not getting the view of mockup camera at all” is for not adding ARDK mock layer.

Can you please confirm that you have added ARDK_MockWorld as is (case sensitive) and the ARDK_MockWorld layer is being assigned MockupScene in the inspector window?

Note: When you change the layer, a dialogue box will appear asking you to apply to all of its children, click ok.

Hope this helps.

@Andrew_Ted_Tedford I can’t try 2019 LTS as I’m using a Mac M1

@Umaiya_Doddamani1 Yes I did add this layer and apply it to its children.

And to be more specific after I did add info in the Mockup prefab the layer I was able to see the Mockup environment when I would play the scene. But I wouldn’t be able to interact with it properly (and this is for the segmentation example scene provided with the ARDK).

+1 to that. The mockup setup seems completely uninteractable when added to the examples (I’m on Android / Windows). Correct Layer + children confirmed, everything else done according to the video (and indeed, setting it up from scratch does let you navigate).

For me I get the mockup scene to show up but it seems to be break the moment the ‘AR Depth Manager’-script gets added to the camera like discribed in the Occlusion tutorial.

1 Like

as I mentioned elsewhere, your experience matches mine - anything but the planes manager breaks the mockup feature.