Localize a private VPS

Include the following details (edit as applicable):

  • Issue category: VPS
  • Device type & OS version: iOS 15.4.1 on iPhone 13 Pro
  • Host machine & OS version: Mac
  • Issue Environment : Unity
  • Xcode version: 13.4
  • ARDK version: 2.0
  • Unity version: 2020.3.26f1

Description of the issue:
I’ve successfully created a private VPS and can see that it was processed and ready to go.

I’ve made a simple iOS build using the WayspotAnchors scene from the sample project.
However, when I run it I’m immediately getting a “Session Initialized Failed”

Do I need to do anything special to localize with private vps ?

Thanks.

1 Like

I have done the same and I’m facing the same issue (but in an Android build), really don’t know if I’ve missed something somewhere.

I have resolve my issue, apparently it has to do with where you put the license key (or lack thereof), make sure that you put the key only in one place, I’m now using the templates from the Lightship Hub packages, the Lightship Hub comes with a config window where you should put the license key, I have deleted a couple of “resource” folders where the license key was placed or it was blank, including the one that comes with the ARDK examples. I hope it helps.

1 Like

Mario, I tried everything you mentioned making sure the license key is the same.

I am still unable to localise to a private processed VPS.

Hope someone has figured it out.

Okay, I finally figured it out. The template I used previous that did not work is the template generated inside the Lightshiphub!

Several hours later I stumbled upon another ARDK example scenes which contains another wayspot anchor template (imo better since you can restart scanning localization).

As marioleo mentioned above, you need to delete the ArdkAuthConfig key inside the example scene resource folder. (Assets\ARDKExamples\Resources)

Then after you build it and load it up, you can be able to localized.

It’s strange that the template that was in the Unity lightshipHub did not work. Hopefully someone in the dev team notices it.

Hope this helps someone.

Hello Eyal,

Sorry for the delayed response.

We were able to test both of the WayspotAnchors scenes – the first located in the ARDK 2.0 Examples package, and the second located in the Lightship Hub package – and we were able to successfully localize against a private scan.

As Peng Han Kum has pointed out, the issue may be occurring because of a duplicate and/or empty ArdkAuthConfig object.

Can you confirm that your ArdkAuthConfig is set up properly by searching for “ArdkAuthConfig” in your Project view, verifying that there is only one object and that’s located in Assets/Resources/ARDK, and that it contains an API key that belongs to your Lightship account that you’ve created at lightship.dev/account/projects?

Hi Eyal,

We just wanted to check in and ask if you’re still experiencing issues with localizing against a private scan via the WayspotAnchors sample scene?

If so, we’d be happy to help get to the bottom of the issue together.