No object showing in Shared Object Interaction Template

  • Issue category: Multiplayer
  • Device type & OS version: Android
  • Host machine & OS version: Windows
  • Issue Environment : On Device
  • ARDK version: 2.0.0
  • Unity version: 2020.3.33f1

Description of the issue:

I am trying the Shared Object Interaction Template. It seems I have set it up correctly because it works fine in mock environment.

However, when I build on two Android devices (both Xiaomi Mi9), the app starts in both of them, I’m able to JOIN, but I don’t see the Virtual Object at all and the app does not respond to any taps (while it works with mouse clicks in the mock environment).

What might be wrong? Have I not JOINed correctly? And, even if I use just one device as a host, shouldn’t I see the Virtual object as soon as I tap on a mesh area? I suggest you make a video on how to use this template as a User.

Has anybody else tried the Shared Object Interaction Template? Does it work for you?

Hello Manos,

Niantic is out until Tuesday. I have a few questions,

  • When you are joining the session, is your host device connection stable?
  • Is your code for the tapping interaction complete and correct?
  • What layer is your virtual object on?

Please let us know so we can assist you further.

Hi Jason, thanks for reaching out! My problem is mostly derived from the confusion that most users may have with the Templates feature. Let me explain:

In the mock environment, testing the templates is a breeze, generally, everything seems to work as expected. However, nothing is as expected when you build and test on the device. I’m not just talking about the SharedAR template, I’ve also tried other templates. For example:

Mesh Occlusion Template:
[mock] the car moves to the clicked position
[build] the car is just placed in the tapped position
(Also tracking is much slower than plain ARCore - default template setup)

SharedAR Template:
[mock] the virtual object is placed in the clicked position
[build] tapping does not work at all, the virtual object is not visible
(Also tracking is much slower than plain ARCore - default template setup)

So, since a user is under the impression that what she sees in the editor (mock) will also see in the device - without adding any extra code - this does not happen. Am I wrong to assume this?

The shared object template is quite straight forward.

One phone joins a room, and the other join to the same code room.

I notice the main phone should aim at a target location. Then I just tap and both phones will have a rocket instantiated.

I did not do anything extra.

is your phones AR enabled?

So, your reply got me thinking and retested the template. After more than a dozen random taps on the generated grid, I managed to see the rocket after all… So, my problem is obviously on the tapping, it seems to be really tough to detect the plane. I wonder why…

I will try tapping against FeaturePoints instead of planes (as someone suggested in another post) to see if I get better responses to my taps. I’m open to other suggestions though.

Update: I added extra logs and I see that the tapping works ok but the rocket never shows up because I always get SharedSession._isStable = false.
As this is now an entirely different problem, I mark this ticket as resolved.

This topic was automatically closed 2 hours after the last reply. New replies are no longer allowed.