Missing Prefabs in ARDK Pong Example

  • Issue category: Unity Example Package
  • Device type & OS version: Android
  • Host machine & OS version: Windows 11
  • Issue Environment : On Device
  • ARDK version: 1.3.1
  • Unity version: 2020.3.28f

Description of the issue:
I’m trying to get the ARDK Pong example to work, but no matter what I do I can’t get the missing prefab in the scene to show up. I’ve tried remaking a clean project, reimporting the ARDK and ARDK Example packages, following all the steps for getting the project to work on Android, all to no avail.
This issue is related to this post from November, it seems it’s still around 5 months later. It’s this particular prefab on the Join button that is the issue:

Hello Jordan, I’ve forwarded the missing prefab issue to engineering. In the mean-time, the missing prefab should not stop the Pong scene from loading or functioning as intended. The join button appears and functions as intended when entering playmode. Will you elaborate on what you mean by not being able to get the prefab to show up? Are you experiencing any red warnings in the console? If so please provide a copy/paste of your console logs.

Perhaps the issue lies somewhere else, as I still have a black screen when joining the session on both phones. Both are Android and I’ve added the Android Permission Requester component to the scene, requesting access to the Camera, but yeah still a black screen. I thought it was related to the missing prefab on the Join button not enabling something that will turn on the camera, but perhaps you know what could be causing the issue.

Other users have reported a black screen issue and it has been forwarded to engineering. The cause is an incompatibility between ARDK and devices updated to the most recent version of ARCore 1.31. Once updated, reverting ARCore versions through Google Play is not available, though a resolution has been developed and will be made available with the next ARDK in the next few days.

Okay, sounds good. Just to update on this, this black screen issue is still present on the 2.0.0 ARDK version that was released today.

(edit: This issue has disappeared for my Android 11 devices, but still present on the Android 9 device.)

Hi @Jordan, what version of Google Play Services for AR (ARCore) do you have installed on your Android 9 device? The black screen fix that was shipped with ARDK 2.0 should address the issue for ARCore version 1.31. If you don’t have that version installed, could you try updating it to the latest version?

Also, not sure if it’s relevant, but what is the device model that you are testing with?

Just tried it again, and it worked! Apologies, it seems that the issue was the app takes a bit longer to load into the camera on the device then my other two devices for some reason (4-5 seconds). After that time, the camera does turn on. Sorry for the false alarm! The device was a Samsung Galaxy S8, so it’s a five year old device, so I suppose it is expected for it to take a bit longer.

1 Like

This topic was automatically closed 2 hours after the last reply. New replies are no longer allowed.