Directory Not Found for LightshipARDK

Include the following details (edit as applicable):

  • Issue category: Not linking properly
  • Device type & OS version: Android
  • Host machine & OS version: Windows
  • Issue Environment : Unity Editor / Visual Studio
  • Xcode version: n/a
  • ARDK version: 1.0.1
  • Unity version: Unity2019.4.32f

Description of the issue:
Suddenly when I open unity I get errors saying that the directory for lightship ARDK couldnt be found at destination (even though its there), and when I open visual studio it doesnt recognize any of the Niantic namespaces and just errors out saying am I missing a using statement (the using statements are in the script but are just errors).

I’ve been working in the project since Lightship launch with no issues. I do however work on this project between two computers using Unity Collab as version control. My other PC has no problems finding the directories.

Things ive tried:

  • Deleting and repulling project
  • Creating a new project and importing ARDK to see if it worked (it did)
  • Deleting ARDK out of the project and reimporting it
  • Creating new scripts (was a suggestion from goole searching this)

I have noticed that I can go as far as: using Niantic.ARDK, but after that i only find Virtual Studio and Extensions.

Im not sure what else I can try, any help would be great :slight_smile:

Hello Scott, sorry to see you are having issues locating your ARDK installation, and that it’s namespaces aren’t available in your project. Are you able to take a screenshot of the error messages? For the ARDK not found message, have you tried reverting to a previous version of your project through Unity Collab, or resyncing with the project version that doesn’t include these errors? Have you verified the computer experiencing the issue is correctly connected to Collab? You mentioned the issue went away with a fresh installation of the ARDK? Are you able to resync your project at that point? For the namespace issue, are you able to verify that the correct integrated development environment (IDE) is linked in Unity?

You can find this through **Edit **> Preferences, External Tools > External Script Editor.
Another option would be to check that the correct name spaces are included in your scripts. These are included automatically with a complete installation of the ARDK. In your fourth bullet point you mentioned a Google search advising to create new scripts. What scripts were created?

Hello Scott, It’s been a while since we requested more information, but have yet to hear back? Are you still experiencing this issue? I’ll be closing this thread with no response, but please open a new topic if the issue persists.