Neither playback, nor XR Environments working with ARDK3 Beta4

Include the following details (edit as applicable):

  • Host machine & OS version: Mac Ventura M1
  • Issue Environment : Unity Mock
  • ARDK version: 3 Beta 4
  • Unity version: 2021.3.29f

Today I started getting into ARDK3 however, just following the basic steps on how to install it, I have a few issues.

Basically I followed the Installing ARDK3 step-by-step guide (Installing ARDK 3 | Niantic Lightship)

, however I can’t get anything to run ( See videos). Some of the errors I get are:

XR Management has already initialized an active loader in this scene. Please make sure to stop all subsystems and deinitialize the active loader before initializing a new one.
UnityEngine.XR.Management.XRGeneralSettings:AttemptInitializeXRSDKOnLoad () (at Library/PackageCache/

No active UnityEngine.XR.ARSubsystems.XRSessionSubsystem is available. Please ensure that a valid loader configuration exists in the XR project settings.
UnityEngine.XR.ARFoundation.ARSession:OnEnable () (at Library/PackageCache/com.unity.xr.arfoundation@5.0.7/Runtime/ARFoundation/ARSession.cs:342)

No active UnityEngine.XR.XRInputSubsystem is available. Please ensure that a valid loader configuration exists in the XR project settings.
UnityEngine.XR.ARFoundation.ARInputManager:OnEnable () (at Library/PackageCache/com.unity.xr.arfoundation@5.0.7/Runtime/ARFoundation/ARInputManager.cs:24)

No active UnityEngine.XR.ARSubsystems.XRCameraSubsystem is available. Please ensure that a valid loader configuration exists in the XR project settings.
UnityEngine.XR.ARFoundation.SubsystemLifecycleManager`3<UnityEngine.XR.ARSubsystems.XRCameraSubsystem, UnityEngine.XR.ARSubsystems.XRCameraSubsystemDescriptor, UnityEngine.XR.ARSubsystems.XRCameraSubsystem/Provider>:OnEnable () (at Library/PackageCache/com.unity.xr.arfoundation@5.0.7/Runtime/ARFoundation/SubsystemLifecycleManager.cs:68)

Description of the issue:

Thankful for any help! Thanks a bunch in advance

Hi Tobias,

Can you try uninstalling and reinstalling all the ARDK 3 packages from the Package Manager?

Thanks for your answer, still not luck… This is what happened after reinstalling the ARDK:

These are my settings

Lightship is selected also for android and Pc:

Hope to fix this issue soon

OK the issue seems to be using URP. Didn’t know that URP is not supported yet.

I still get the error with the XR Environments through…

Hi Tobias,

Can you double-check that you don’t have multiple versions of ARKit installed? Looking at the video you uploaded, it doesn’t look like you do but the version of ARKit that is being displayed in these errors is not the same as the one that comes with Lightship

So what I did after encountering the error for the first time was reinstalling AR-Kit. That might have caused the difference in the error. Though after creating a new project that does not use URP, but the standard rendering, it worked fine and I did follow the exact same steps.

I see. So are you still getting the warning messages about not having the XRSubsystems?

Also, for your URP issue, it sounds like you might have just needed to add the AR render feature to the URP assets as well. It doesn’t come included since it’s only installed after ARFoundation is installed (which is installed along Lightship as a dependency) so you have to add it in afterward. I ran into the same issue with AR Foundation a while back.