Stuck with Development on Windows machine

  • Issue category: Development on Windows and Remote Mode
  • Host machine & OS version: Windows 10
  • Issue Environment :Unity Mock and Remote
  • ARDK version: 1.1.0
  • Unity version: 2019.4.29f and 2019.4.33f

Description of the issue:

Hey all. I’ve downloaded ARDK Version 1.1.0 and the 1.1.0 examples. When trying to run the Depth example, I can build and run to Android just fine. However, trying to run this scene (or any scene really) in the editor gives the the following errors two errors:
(1) System.DllNotFoundException: ardk_client_platform
(2) Exception: An exception occurred in a method subscribed to an ARDK event, check the device logs for more information

The documentation says this about development on Windows

My understanding of this is that it’s impossible to use Virtual Studio’s Mock Mode on Windows, but that the two errors I got above are normal for Windows and to be expected. Can anyone confirm these two details?

Secondly, I’ve tried to run ARDK scenes in Remote Mode without success.

I’ve installed the Remote App on my Android device and I can get it to connect to Unity (although I do have to restart the remote app everytime I restart the scene, otherwise I can’t get it to reconnect). However, the remote app never progresses past the green screen for me and I’ve tried all the troubleshooting tips outlined here Playing in Remote Mode. I’ve also tried manually turning on all the remote app’s permissions, but still no luck.

Any help with the two issues outlined above would be greatly appreciated, thanks!

1 Like

Hello Hap,

Those 2 errors you listed are expected when developing/building your application on Windows. These are due to the ARDK native Mac environment, though they don’t impede building or developing with Lightship on Windows PC.

For the Remote App issue - A USB connection is required for a test as Wireless is not available on Windows at this time. A green screen means that you have connected successfully. Other features like chat and gameplay are not implemented.

Regarding Mock Mode, it is available on Windows, and can be tested between multiple virtual devices by following the Shared Experience video tutorial found here:, or through the ARDK manual here: Note that building for Android version 11+ requires further gradle integration.

It seems you are on the right track, and that the ARDK is working as expected.

1 Like

hi @Umaiya_Doddamani1 ,

Can you confirm that mocking AR features (not networking) is impossible on windows machines?
i.e I’m trying to add the MockupScene prefab, place everything at the right layer, etc. - but I’m still not able to use ARMesh (or planes, anything) to mesh that prefab when playing in editor. I’m not sure if this is a windows thing, but even the scene ExampleMockPlaythrough - which indeed has a planerenderer - doesn’t seem to work in play mode? (I do see the “foo” and “bar” entities spawn, but meshing, plane recognition, everything else doesn’t seem to recognize the mockupscene meshes?)

1 Like

Hi Michael,

May I ask you to open this topic up in the Lightship forums so the community can see the answer?
We appreciate your understanding.

Hello Umaiya, I am getting the same errors, I understand they does not stop me from building stuff but while having them I can no run the app in playmode in Unity to test it, so, that means the only why to test the app is throught the Remote App?

I have test it on my device using the remote app but with does errors is the same, I am not allow to see and interact with what I am building. :frowning:

Hi Marina,
We could support through this forums only. May I ask you to create a new topic up in the Lightship forums?
We appreciate your understanding.